51

Re: Virtual Machine Version

Version 4.0.15 still gives me the same error,

[    2.909488] r600_cp: Failed to load firmware "radeon/SUMO_pfp.bin"
[    2.909546] [drm:evergreen_startup] *ERROR* Failed to load firmware!
[    2.909597] radeon 0000:00:01:0: disabling GPU acceleration
_ 

Then it just sits there with a blinking _ forever.

Re: Virtual Machine Version

Ok, well now that you posted the error I know what the problem is it is the kernel firmware it's not the driver that I included so yes it will fail. I will now include the kernel firmware and rebuild once it is done I will let you know to try again.

Re: Virtual Machine Version

Try now.

54

Re: Virtual Machine Version

The error still exists. I should add that the error is only without the nomodeset; otherwise with nomodeset I get three shades of green bars that load and progress at different speeds to the right at the bottom of the screen on top of each other and then after some tens of seconds the green bars turn red, grey, and blue that ends in a total black screen.

Re: Virtual Machine Version

OK, seems that the option works (nomodeset), but something else doesn't now I should figure out what exactly doesn't work - strange.

Re: Virtual Machine Version

Well seems that earlier when I tested and when it didn't boot - it really didn't.
I recreated the appliance:
http://susestudio.com/a/EmL6GN/secured-os--2

Try now and again with nomodeset option during boot.

I also added this:

# recreate initrd without KMS, if the use of KMS is enabled in initrd
if grep -q NO_KMS_IN_INITRD=\"no\" /etc/sysconfig/kernel; then
   sed -i 's/NO_KMS_IN_INITRD.*/NO_KMS_IN_INITRD="yes"/g' /etc/sysconfig/kernel
   mkinitrd
fi

From here both recomended for nvidia and ati.

57

Re: Virtual Machine Version

Wow, I just wrote a long post and I lost it all. Anyway, here's trying to see if I can remember it all,

It worked. I used ImageWriter for Ubuntu; the one where I had to first rename the .iso file as a .img file in order to write to USB. The hardest part was editing all the partitions in order to install to my hard drive instead of the default USB drive. Another hard part was that the checkboxes looked the same whether they were selected or not, so I was a little bit blind. There were a few other bugs, one of which helped me know it might work.

One, during or after the green bars thing there is a logo in the bottom right corner of my screen that says, "AMD Unsupported hardware". I waited for something to happen and sure enough a couple minutes after the bars turned colors it loaded the login screen! From there I entered the desktop by logging in and then the LiveInstaller. I think installing the gflrx driver will fix this, I have not got around to it yet, but it persists through the LiveCD, installation process, and into my installed desktop experience right now.

How do I install drivers in opensuse?

Two, if I click on the LiveInstaller from Yast twice it opens two windows, one of which asks to cancel or continue with the message that says something like, Yast2boot needs to be closed before you proceed with installation. Continuing will not work, so I press cancel and then exit the second LiveInstaller window. To fix this bug, I think I just needed to single-click the LiveInstaller button.

Three, "Timezone couldn't be found. Verify the integrity of the Yast-2-theme-* package." I wonder if this error inside the LiveInstaller is normal and just means that one has to manually set their timezone? This I did and installation continued normally.

I alreday installed some Firefox addons. Next I will install the drive to see if the error logo will disappear. I don't know whether the startup script in your last comment helped, worked, or was used. But, thank you for all your help. Yay, finally done; I'm using SecuredOS from my hard drive right now!

Last edited by tau (2012-09-20 17:32:11)

58

Re: Virtual Machine Version

I have now installed the fglrx driver and the "AMD Hardware unsupported" logo has disappeared, thanks god. I have found another unsettling error though. When I try to change my resolution with System>Preferences>Monitor Settings an error pops up, "Unable to get monitor information!" I would like to open the Monitor Settings tool to change my resolution, any tips? Am I missing a package? If I am, wouldn't the error says so? It does not.

I do not see the Boot option in Yast in order for me to change to grsec. I have tried switching to grsec with the grub2 menu that loads everytime I boot the computer, but lots of errors about /dev/RAM happen. I see Boot Loader in Yast, but that does nothing but mess with switching between grub2 or anothe type of bootloader, I think. If Boot Loader is the correct utility, how do I use it?

Last edited by tau (2012-09-20 18:10:47)

59

Re: Virtual Machine Version

I'm trying to get sound to work. Reading your installation instructions, can you expand on step 3 of Fixing Your Sound--how do I configure the sound card in normal mode? Do I need to know what sound card I have to pick the right driver? If so, how do I find out which sound card I use?

Last edited by tau (2012-09-20 19:12:10)

Re: Virtual Machine Version

Ok Step 3. Well the card is usually at index 0 - mine is (HD48x0 - intel something). in step 3 you select the card and you click on the Edit button you then configure it with Normal. About the kernel, yes I know it is because of the boot-loader they are many I have to remove them, I added more because of the EFI - that we discussed, I now reallize this was not a good idea. You have in the installation instruction a screenshot which shows how to configure the boot entry for GrSecurity from YaSt>Boot. But this might not work very good in the moment, I will try to now resolve the issue with the bootloaders. You can use the bootloader of ubuntu to set it up - I think it should work well.

Re: Virtual Machine Version

Soooooooo I finally figured it out! With the boot loader. Install this package - kexec-tools then the menus will be displayed and use only grub not grub2, grub2-efi, lili, elilo just grub. I will now edit the appliance and test again.

62

Re: Virtual Machine Version

I've had to reinstall from scratch twice after not being able to load a kernel from grub. There is an option that comes up just when you select grub from Boot Loader<Yast and I don't know which one to choose. Some of the options go like this, convert boot setting from disk, convert old boot settings, perform new boot settings, and like three more. I've tried convert old boot settings and perform new boot settings. The new boot settings for grub from grub2 made the list of kernels appear that show up in the LiveUSB when it's time to enter boot options, so I think that might be the right one to press. But, when I set the selection to the grsecurity one I rebooted and the same error as before with the /dev/ram numbers came up. When I did convert from old boot options I did not know which sda number to put where because the only one it would allow me to pick for root device was sda1 but you have sda2 chosen in the instructions for that, and because of that I chose resume=/dev/sda2 for optional kernel command line parameter instead of resume=/dev/sda1 like in the instructions. How am I supposed to do it exactly? I think I can figure out which partition I have root (i.e.

Re: Virtual Machine Version

Yes exactly, you first select the bootloader for me it worked with grub and click install bootloader or something like that. At first I also thought that when I clicked convert it displaied the menu, but now I understand that actually it was the install button. I will try to update the install instructions. But the main idea is to see the menu on the previous tab so you can adjust whatever you want. Well about the partition I'm not sure if it should be sda1 or 2 in your case it is individual. But if it was sda1 leave it that way and it should be fine. You basicly "clone" the entry you already have and create one for GrSecurity by replacing the kernel and the initrd image. I have to admit I'm surprised at how they changet Boot in YaSt - it seems nice, but I think they have lot of work to do - to many stuff doesn't work/experimental or is not intuative. And this error with the RAM they seem to be from the bootloader.

Re: Virtual Machine Version

The RAM Errors - OMG I think I will have to recompile the kernel again big_smile X-)
"Did you all Disable CONFIG_SYSFS_DEPRECATED _and_ CONFIG_SYSFS_DEPRECATED into the kernel config?"
http://forums-web2.gentoo.org/viewtopic … art-0.html

Re: Virtual Machine Version

I think I understand the reason why the kernel breaks. It has to do maybe wiht udev - and probably with the RAM image initrd - sounds logical since the kernel doesn't even boot in this case I might be able to fix it sooner, but I will have to experiment.

66

Re: Virtual Machine Version

For some reason all my edits on my last comment did not make it through. Well, anyway, what I also asked was to compile this patch (https://grsecurity.net/test/pax-linux-3 … st32.patch) to be up to date now that OpenSuse went to version 12.2 with the 3.4 kernel. I think you will only have to do it once per OpenSuse cycle because I think grsecurity.net does not update to the latest 3.4 kernel, but just has one of them. Even if they go to something like 3.4.9 at least the 3.4.anything will be the same as the 3.4 of OpenSuse 12.2.

So the sda2 is the one with / partition, then is sda1 optional kernel command line parameter meant for the swap partition?

I had three sound drivers that I deleted and after I configured two of them with "normal" I got sound, so do I leave the third one deleted? Because when I configure the last of the three drivers it disables sound again.

Last edited by tau (2012-09-21 21:13:35)

67

Re: Virtual Machine Version

I don't think I need the extra software package fglrx64_legacy_xpic_SUSE122 because I got the driver to work with this (http://en.opensuse.org/SDB:AMD_fglrx#Pr … UI_-_YaST2) and the one you included with SecureOS is the legacy version, anyway.

Re: Virtual Machine Version

I maybe will have time tomorrow evening to compile the new kernel. I still am not sure if this will fix the issues with the ram errors. The resume option "tells the kernel where to find the suspend-to-disk image to resume from (for swsusp and suspend2, respectively) ".

Yeah you can leave everything else if sound works. Ok well I can include the driver you just posted.

I'm glad it started working, I'm still wondering if the issues with the kernel are from the kernel or from the bootloader or udev. I will let you know when I have some results.

69

Re: Virtual Machine Version

Yeah, you can just add the repository for the fglrx with (http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_12.2/), then I can add the package from there with Yast once I boot in after installation.

The designation for the kernel to find the "supsend-to-disk" image sound like what the swap is for because swap is the partition for where the kernel suspends the RAM to hard drive during things like sleeping, and Live Desktop for running off of CD/USB. So, the root device will be for the partition / is on and the resume will be for the partition swap is on, each depending on which partition I setup from installation. Because I have to manually edit my partition tables (or else it installs to my USB drive instead of my hard drive) can you tell me what is the sda number that automatically gets set for root (/) and resume (swap) when someone else (like you) uses the LiveInstaller? You don't have to proceed to write to disk, just tell me the proper setup that it lists between sda partitions and the part of the OS which will install to them, correspondingly--does swap go to sda1 and root go to sda2 when automatic installation works normally (i.e. when it selects the hard drive to write to instead of the USB drive).

I do not think the issues are with udev, because I have no idea what it is or what you are talking about when you describe the udev issues. If I had to guess, I think the trouble lies with the bootloader because I don't know how--by which option to choose--to convert the grub2 into a workable grub legacy. There is literally an option menu that pops up, so I think all I need to know is which option to select and we can work from there.

Last edited by tau (2012-09-23 02:47:13)

70

Re: Virtual Machine Version

You're right it is a problem with udev, it is actually udevd in fact. Here is one of the error messages (the only difference between the rest of them is the ram# and time) when trying to boot grsec,

udevd[1758]: inotify_add_watch(6, /dev/ram2, 10) failed: No such file or directory

Maybe updating the kernel to 3.4.8 will help solve the udevd problem?

Here is the initial ram disk content for the section name  with openSUSE 12.2 in the Boot Loader that does not work either, "/boot/initrd-3.4.6-2.10-default-kdump". The only section name that does boot is Kernel-3.4.6-2.10-default with the intial ram disk box filled with "/boot/initrd-3.4.6-2.10-default". So, I found I have not been locked out of my system entirely with the last boot loader conversion step, the default kernel still works as noted. I could probably get the openSUSE 12.2 section to work again if I delete the non-existant "-kdump" tag from the initial ram disk input. If I am able to boot back into the desktop with the Firefox Add-ons installed by changing openSUSE 12.2 to the same initial ram disk as the default section then apparently a problem with converting the grub2 to grub legacy was that it added the "-kdump" to the end of the filename, which does not lead to any known file in the /boot directory. Still leaves us with the grsecurity udevd problem.

Last edited by tau (2012-09-24 02:44:48)

71

Re: Virtual Machine Version

No trouble booting the openSUSE 12.2 section (it's the first on the list) now that I have its initial ram disk to an existing default kernel with the extra word, "-kdump". I found no add-ons like I expected, but I now remember that is because I was using a clean reinstallation because once I got locked out the first time I decided to try again without any extra effort first. Anyway, at least I recovered my second installation. Which bring me to this.

I think I chose the correct option in the menu that pops up when changing from grub2 to grub legacy because the boot loader section do not contain sda at all in their Root Device or Optional Kernel Command Line Paramter boxes. Here is what they say now, "/dev/disk/by-id/ata-OCZ-VERTEX4_OCZ-8591A6KR7W3PX1S2-part1" for the root device input, and "resume=/dev/disk/by-id/ata-OCZ-VERTEX4_OCZ-8591A6KR7W3PX1S2-part2 splash=silent quiet showopts" for the Optional Kernel Command Line Paramter box.

72

Re: Virtual Machine Version

I've got some great news; about the checkboxes' indifference. I got checked boxes to show a checkmark by changing System>Preferences>Customize Look and Feel>Widget>Adwaita from 04-Crunchy-grey. It was a problem with the 04-Crunchy-grey widget that probably showed the wrong color to be the same as the background color, which is why I could not see the check marks or know which boxes I checked off. Fixed!

73

Re: Virtual Machine Version

I've got some bad news with the sound. When I reboot and get to the last step for the Sound and Video>Mixer I get three choices of one flavor of Sound card: HD-Audio Generic (Alsa mixer). So, I go to the Select Controls button and select the only option that is available IEC958, click close, then it appears in a tab called Switches inside Mixer. The only option left to choose from, from there is Quit, but no matter whether I Quit or Exit the X button at the top right corner of Mixer, whenever I come back to it I have to reselect IEC958, it does not save. I don't even know where I'm supposed to adjust the volume--in the Yast>Sound>drivers? I think I may need to install a sound card so that I can get a different one other than HD-Audio Generic (Alsa mixer). However, I have no clue how to find out which sound card I have in order to install the driver through the package manager, if that's how you do it.  Yes, I disabled Pulse Audio support. Any suggestions? Is it like how I needed the driver for my video, now I need the driver for my sound?

Re: Virtual Machine Version

Well the sound. Look at the Main Board specifications and you will also find what kind of sound card you have on the board. Repeat the steps the trick there is to remove the configuration of all sound cards configure them, remove pulse audio on all of them and right after that configure the mixer. What I really notice in OpenSuse is if your sound breaks then you have to reconfigure it again until you see it in the mixer -after doing this settings it is OK. But if you leave it and try to configure your settings in the mixer later you are lost. You don't need a driver you have it already, it comes with the kernel modules. About the bugs thanks for reporting them. I'm currently working on the kernel since this seems to be a main issue. Also i found some bugs in suse studio and reported them and I hope they fix them. One other approach how to find what is the sound card - when you configure the sound from yast and click on test if you hear a sound this is your sound card - good luck.

75

Re: Virtual Machine Version

You're welcome for reporting the bugs.

I found that I was able to have sound after reboots, but the only sound I ever had was the test sound in the Yast>Sound>Other>Play Test Sound on the sound card with index 1. When I set sound card on Index 1 to >Other>Set as the Primary Card or if I do not configure one of the sound cards before a second one, I will not hear sound, and I can hear sound on any of the sound cards as long as it has the Index 1 with another one configured at Index 0. Previsously I did not know the configuration was okay in this regard because I played test sound on Index 0, instead of Index 1, the second sound card.

I don't know what configuring the Mixer is supposed to do? It seems like it does nothing. No more options pop up to configure anything else than the nonpersistant IEC958 control. "Control" of what? I don't see it doing anything. But, I've got worse problems now.

I thought that since I had changed some settings in PulseAudio Equalizer that doing so might have caused the sound not working after doing all the steps (by the way I tried adjusting Select Controls of Mixer both before and after rebooting and the instructions say after rebooting). So, I uninstalled it and then the sound didn't even work in Yast Test Sound of Index 1 anymore, even after reinstalling the package and rebooting mad .

Last edited by tau (2012-09-24 22:26:06)