Re: Terminal Doesn't Work

Yes, it matches, here is my output ... ~/Downloads$ md5sum Secured_OS.x86_64-4.0.2.oem.tar.gz
f11f16ee56e0e01e25f57443b70874ac  Secured_OS.x86_64-4.0.2.oem.tar.gz

I didn't get an interrupted download, but I did get very variable download speeds, sometimes it would say 5 minutes left, then it would say 15 minutes left. Or with the full NetSecL OS version it would go back and forth between about an hour left and tens of minutes. Either way, it would take about twice as long as the shorter time value.

Here is the output for running image writer with sudo priviledges,
~/Downloads$ sudo imagewriter
Image: /home/user_name/Downloads/Secured_OS.x86_64-4.0.2.img
Target Device: Memorex TD Classic 003B (/dev/sdb)
Unmounting all partitions of /dev/sdb:
Trying to unmount /dev/sdb1...
/dev/sdb1 successfully unmounted
Executing: dd if=/home/user_name/Downloads/Secured_OS.x86_64-4.0.2.img of=/dev/sdb
Wrote: 119537664 bytes
Wrote: 365953024 bytes
Wrote: 609222656 bytes
Wrote: 736100352 bytes
Wrote: 756023296 bytes
Wrote: 772800512 bytes
Wrote: 787480576 bytes
Wrote: 802160640 bytes
Wrote: 814743552 bytes
Wrote: 824180736 bytes
Wrote: 832569344 bytes
Wrote: 839909376 bytes
Wrote: 848297984 bytes
Wrote: 855638016 bytes
Wrote: 864026624 bytes
Wrote: 876609536 bytes
Wrote: 891289600 bytes
Wrote: 905969664 bytes
Wrote: 920649728 bytes
Wrote: 936378368 bytes
Wrote: 951058432 bytes
Wrote: 965738496 bytes
Wrote: 982515712 bytes
Wrote: 1004535808 bytes
Wrote: 1026555904 bytes
Wrote: 1048576000 bytes
Wrote: 1070596096 bytes
Wrote: 1092616192 bytes
Wrote: 1115684864 bytes
Wrote: 1137704960 bytes
Wrote: 1160773632 bytes
Wrote: 1182793728 bytes
Wrote: 1204813824 bytes
Wrote: 1221591040 bytes
Wrote: 1243611136 bytes
Wrote: 1266679808 bytes
Wrote: 1288699904 bytes
Wrote: 1311768576 bytes
Wrote: 1332740096 bytes
Wrote: 1351614464 bytes
Wrote: 1375731712 bytes
Wrote: 1397751808 bytes
Wrote: 1420820480 bytes
Wrote: 1443889152 bytes
Wrote: 1465909248 bytes
Wrote: 1484783616 bytes
Wrote: 1500512256 bytes
Wrote: 1522532352 bytes
Wrote: 1544552448 bytes
Wrote: 1567621120 bytes
Wrote: 1589641216 bytes
Wrote: 1609564160 bytes
Wrote: 1627389952 bytes
Wrote: 1650458624 bytes
Wrote: 1672478720 bytes
Wrote: 1695547392 bytes
Wrote: 1717567488 bytes
Wrote: 1739587584 bytes
Wrote: 1760559104 bytes
Wrote: 1781530624 bytes
Wrote: 1799356416 bytes
Wrote: 1820327936 bytes
Wrote: 1842348032 bytes
Wrote: 1864368128 bytes
Wrote: 1884291072 bytes
Wrote: 1904214016 bytes
Wrote: 1927282688 bytes
Wrote: 1951399936 bytes
Wrote: 1975517184 bytes
Wrote: 1999634432 bytes
Wrote: 2022703104 bytes
Wrote: 2042626048 bytes
Wrote: 2065694720 bytes
Wrote: 2084569088 bytes
Wrote: 2106589184 bytes
Wrote: 2129657856 bytes
Wrote: 2152726528 bytes
Wrote: 2175795200 bytes
Wrote: 2198863872 bytes
Wrote: 2222981120 bytes
Wrote: 2245001216 bytes
Wrote: 2268069888 bytes
Wrote: 2292187136 bytes
Wrote: 2314207232 bytes
Wrote: 2338324480 bytes
Wrote: 2361393152 bytes
Wrote: 2383413248 bytes
Wrote: 2402287616 bytes
Wrote: 2424307712 bytes
Wrote: 2447376384 bytes
Wrote: 2470445056 bytes
Wrote: 2493513728 bytes
Wrote: 2517630976 bytes
Wrote: 2540699648 bytes
Wrote: 2564816896 bytes
Wrote: 2585788416 bytes
Wrote: 2607808512 bytes
Wrote: 2630877184 bytes
Wrote: 2654994432 bytes
Wrote: 2672820224 bytes
Wrote: 2695888896 bytes
Wrote: 2718957568 bytes
Wrote: 2742026240 bytes
Wrote: 2765094912 bytes
Wrote: 2789212160 bytes
Wrote: 2811232256 bytes
Wrote: 2835349504 bytes
Wrote: 2858418176 bytes
Wrote: 2881486848 bytes
Wrote: 2905604096 bytes
Wrote: 2928672768 bytes
Wrote: 2952790016 bytes
Wrote: 2969567232 bytes
Wrote: 2992635904 bytes
Wrote: 3015704576 bytes
Wrote: 3037724672 bytes
Wrote: 3060793344 bytes
Wrote: 3083862016 bytes
Wrote: 3106930688 bytes
Wrote: 3129999360 bytes
Wrote: 3149922304 bytes
Wrote: 3171942400 bytes
Wrote: 3193962496 bytes
Wrote: 3217031168 bytes
Wrote: 3240099840 bytes
Wrote: 3262119936 bytes
Wrote: 3279945728 bytes
Wrote: 3291480064 bytes
Image Secured_OS.x86_64-4.0.2.img successfully written to/dev/sdb

Re: Terminal Doesn't Work

Well seems OK to me. I tested again it really took a coffee to boot, but after that the performance is great you can use the OS right of the USB - I really was amazed that it can work so fast off the USB. So what happened on my side it boots - you see the logo of NetSecL, but takes time, the monitor sleeps in energy saving mode - you hit any key and it wakes, you will see the login prompt. When you boot do you hit F12 to choose to boot from USB? After that do you see the logo of NetSecL? I really don't see why it doesn't work on you side - seems that the md5sum is ok and transfer to usb to, so it should work.


Re: Terminal Doesn't Work

Yes, first I press F11, it doesn't happen to be F12 for me, in order to change the temporary boot order to boot the USB first. I have to do this because if I don't I can have the USB plugged in and it will still just load the hard drive. So, I do the F11 boot change to load the USB image. Then, yes again, I also get the NetSecL logo. Then I wait for a few hours (within the first hour the USB LED stops flashing continuously and turns into continual flashing), come back and hit some keys (e.g. arrow keys, escape key, moving mouse vigorously, I'll try pressing the enter key next and hopefully it won't erase my hard drive blind). But, still no awakening. How long do you wait for the monitor to wake up? As I've said before, sometimes I wait all night (e.g. about 12 hours).

Did you know that when you are logged in to this site I can not access it? It makes an infinite loop and the page loading times out.

Last edited by tau (2012-08-25 22:01:12)

Re: Terminal Doesn't Work

>Did you know that when you are logged in to this site I can not access it? It makes an >infinite loop and the page loading times out.

Just tested, nothing happens at least on my side.

Nooo, 12 hours is really long period not more than 10-15 minutes. Something seems wrong here I think the part with the awakening, but I'm not sure what can cause this. Lets try this - turn off the monitor while it boots - 10-15 min. Turn the monitor on. Hit the Up arrow key it should wake on the moment not more than 20 sec. Hmmm I know this seems stupid but just a thought is your keyboard ps2 or USB?


Re: Terminal Doesn't Work

I also get see the option to either select SecureOS, SecureOS with Grsecurity, SecureOS recovery, and SecureOS with Grsecurity for recovery. The monitor falls asleep after I select one of the options.

My keyboard is USB and so is my mouse. I noticed a strange thing the last time I just tried to do this again is my Num Lock key is not lit up when I boot the USB even though my BIOS explicitly says to do so. Then, when I hit the NumLock key while the monitor sleeps, it does light up, but when I press the Windows key the light goes out; same goes for the Caps Lock and Scroll Lock lights when I press the Windows Key after they are lit up.

My graphics driver is VESA:SUMO that I found on System Settings>Details on Ubuntu.

10-15 minutes sounds about right for the time where the USB LED goes from continuous flashing to continual flashing, the difference being that after 10-15 minutes the LED goes from flashing all the time without interruption to flashing for a couple seconds, then taking a couple second break, then flashing for a couple seconds, then taking a four second break, then flashes a couple seconds, then takes a ten second break, then flashes a couple seconds, then takes a fourteen second break before starting the flashing cycle all over again starting with the two second break. I wish there were a memory test for USB drives as well as the usual RAM option with some Live medias because maybe my USB drive does not function properly. Do you get the mismatch of md5sum hashes between /dev/sdb and the .img file?

Last edited by tau (2012-08-26 00:40:53)

Re: Terminal Doesn't Work

The hashes should mach although I have never tried in theory they should. However you said it boots so it seems fine to me. Do you have a PS2 on the Motherboard? If you have and if you have a PS2 keyboard or borrow one - try waking up with it. I have seen some cases where the system doesn't respond to USB keyboard.


Re: Terminal Doesn't Work

I waited over 25 minutes this time before pressing keys with a PS2 keyboard and it still did not work. Would a PS2 mouse work? I only have space for one PS2 port though; my motherboard has one slot for both a PS2 mouse and PS2 keybard, but it only fits one at a time.


Re: Terminal Doesn't Work

I'm gonna figure out how to install it on a virtual machine. Did you still want me to look for the graphics driver by using a virtual machine? How should I find it? Is it still worth using it on a virtual machine?


Re: Terminal Doesn't Work

In my virtual machine adventures with AQEMU I have so far figured out that KVM does not support booting with USB? I will have to take my old DVD drive out of my old computer, install it in my new computer, then try to install NetSecL with LiveDVD, and if that does not work I will have to try to install NetSecL with LiveDVD on a virtual machine. I need to know of a way to use a virtual machine without a DVD player (e.g. another way to use LiveUSB--perhaps with a different VM manager than AQEMU--or instruction needed to be able to boot Linux kernel from hard drive, if that's possible) before I want to proceed with that option to boot with DVD?

Re: Terminal Doesn't Work


Re: Terminal Doesn't Work

Right, I forgot about that download option, sorry you had to remind me. Well, I got it running on the vmplayer! It will stay in the virtual machine I created if I installed it, right? But, that's okay because I'd still get the benefits of grsecurity and dnscrypt-proxy, right? Is there any debugging I need to do for you now that I have a working NetSecL?

Re: Terminal Doesn't Work

Yes it stays there and you can have the benefits of GrSecurity inside the virtual machine. No no info is needed, because it is virtual. Enjoy. I will close this topic and make FAQ out of it. Feel free to open another topic.